Jump to content
civitan.erichanson

T5 Light Fixture Help!

4 posts / 467 viewsLast Reply

Recommended Posts

I have an 8 bulb T5 fixture that died two plus years ago.  I don't remember how or why.  So I replaced it with a Current LED which is not great, doesn't obviously put out the light the T5s did.  The fan does not go on and I do not see the starters fire.

 

Are there any electrical wizards on here who might be able to help me diagnose and rewire, or should I call an electrician?

 

An 8 bulb fixture replacement is out of budget.

 

I'm in Frederick MD.

 

Thanks,

 

Eric 

Share this post


Link to post
Share on other sites

If the fan doesn't come on either, it makes me wonder if power is even getting past the on/off switch, or if there's a blown fuse somewhere. Do you have a voltmeter handy and do you know how to use it? Does the unit have a built-in timer that might have failed?

Share this post


Link to post
Share on other sites

I agree with Tom, sounds like a power supply issue. An eight bulb fixture would not have a single ballast so if all the lights are out and the fans then I'd check for a fuse or faulty switch.

Share this post


Link to post
Share on other sites

can you be more specific on model? I have an ATI 8 bulb unit and have replaced the ballast once, it wasnt very hard and they cost around $25 bucks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...