Jump to content
Sign in to follow this  
blaze98

Old RODI unit

Recommended Posts

I have an older model Typhoon III Ro unit that I haven't used for a few years. I was wondering if replacing the fittings would help get this unit back on it's proverbial feet. I have replacement media for it already, I'm just concerned with replacing the hoses and connectors. Any help with this would be greatly appreciated.  

Share this post


Link to post
Share on other sites

They may not check the forum all the time. Try sending something through the contact page on their website. You can also text them at (772) 461-0256. I just did that and received a reply. AWI has been a valued, long-time sponsor of WAMAS. Many of us here have their setups and we frequently offer one at the raffle in our meeting(s).

Share this post


Link to post
Share on other sites

BTW, if you haven't used it in a few years, you'll probably want to change out the filters and the RO membrane. (Don't forget the membrane!) I've never had a problem with the fittings when I've refurbished/updated one of their systems. But all of those systems were kept indoors in controlled environments. If the unit's been sitting for a really long time in an uncontrolled environment, it's possible (I guess) that you may have to change out the o-rings on the canisters and possibly any leaky fittings you might encounter. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×