Jump to content
Sign in to follow this  
SixtyFeetUnder

Typhoon III ASOV Issues

6 posts / 1331 viewsLast Reply

Recommended Posts

I'm not sure if this is associated with the same set of issues discussed in a below thread but I have some concerns and wanted to see if anyone else dealt with these. Upon my sump filling I would assume the ASOV would actually shut off the waste water running to the drain. Instead the unit makes a muffled, grumbling noise and vibrate sending a bass sound through the wall it is attached to (note this can be heard from two rooms away). In addition waste water still runs down the drain when it should shut off.

 

I was told that trapped air could create some sound for the first few days but it has now been running about a month without improvement. The vibration and noise is concerning enough that i shut off the saddle valve last night to sleep without worry. I've ordered a pressure gauge to put near the inisaddle valve from the line out to see if my lines are highly pressurized causing the problem but tend to think this might be a busted ASOV. Any similar experiences or guidance here? thanks!

Share this post


Link to post
Share on other sites

Yep, I had the same issue after running my typhoon 3 (but it had been running for years). I called them and was told it has to do with build up in the ASOV. You can either open it up, clean it with a flat head screw driver and reassemble (May do the trick, or order a new ASOV for $20. But that is definitely what it is. They are very responsive to calls as the other member mentioned.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites

Moderator close thread.

I just realized I replied to my own thread from years ago.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
54 minutes ago, SixtyFeetUnder said:

Moderator close thread.

I just realized I replied to my own thread from years ago.
 

Pretty funny if you ask me.

 

Happy for the update and tip, though. It adds to the thread and our collective knowledge.

 

Thanks for the update, even if it took almost nine years....

 

I'd like to leave the thread open, though, so that others can add their experiences / solutions in the future. Maybe in 2028? :lol2:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...